しばらくの間(15分~20分)、vSphere Clientから接続できない問題が発生

スポンサーリンク

Vmware ESX 4.0 Update2でのこと。
※ESXiではない。

ESXホストマシンを起動すると、
しばらくの間(15分~20分)、vSphere Clientから接続できない問題が発生…。
WebブラウザからのHTTP(HTTPS)もしばらくは正しく応答されない…。
SSHでのリモートアクセスなら、すぐに繋がる…。

ちょいとググってみたところ、以下のサイトでこの現象について書かれている。
●VMware KB: Cannot connect to ESX 4.0 host for 30-40 minutes after boot

/var/log/messagesログを確認すると、

Sep 27 11:14:20 esx02 xinetd[2973]: START: vmware-authd pid=21102 from=127.0.0.1 
Sep 27 11:14:20 esx02 xinetd[2973]: EXIT: vmware-authd status=255 pid=21102 duration=0(sec) 
Sep 27 11:14:20 esx02 xinetd[2973]: START: vmware-authd pid=21103 from=127.0.0.1 Sep 27 11:14:20 esx02 xinetd[2973]: EXIT: vmware-authd status=255 pid=21103 duration=0(sec)

みたいなメッセージが何度も繰り返し表示される。
15分~20分が経過し、「status=255」が「status=0」になるとvSphere Clientで接続出来るようになる。

There is a DNS server defined in /etc/resolv.conf on the ESX host, but the DNS server is unreachable. This issue typically occurs on newly installed servers where the network infrastructure is under construction and where DNS is not available.

ということらしい。

ESXホストのIPアドレスを検証用のものから、
基盤接続用の運用IPアドレスに変更したタイミングで今回の現象が発生している。
運用IPアドレスからはルーティングの都合で、キャッシュDNSサーバーに到達できない状態…。
つまり、DNSで名前解決が出来ない状態。

とりあえず、ESXホストに設定しているDNSの情報を削除し、
/etc/hostsファイルに最低限の名前解決用の情報を設定してみた。
そうしたところ、ESXホスト起動後、すぐにvSphere Clientから接続できるようになった。
/var/log/messagesでも、すぐに「vmware-authd status=0」のメッセージが出るようになた。

一応解決したが、
この問題は発生する原因についてはよく分かっていない…。
(起動時に、vmware-authdが何をしているかなど…。)
なので、もうちょっと調べてみよう…。

スポンサーリンク

 

SNSシェアボタン

  • このエントリーをはてなブックマークに追加