VLAN間ルーティングの実装をする。

スポンサーリンク

VMware ESXi上のVLAN間で通信(VLAN間ルーティング)できるようにしたい!

前回の続きから。

CiscoルータとCatalystスイッチを用意してVLAN間ルーティングの実装をします。

Photo by: Bob Mical

ESXiに搭載されるNICは1つだけ。 VLAN間ルーティングの実現だけでなく、 普段使用しているESXi管理用PCから ESXiのサービスコンソール(下図では)への接続が出来るようにする。

ESXi管理用PCの位置は、元々の場所から変えたくない。そうなると、自宅に構築するVLANルーティング用ネットワークは下図の通りになりそうです…。

vlan_20110519_01

で、この図にVLAN間の通信経路と、管理用PCとESXiとの通信経路を追加すると下図になります。

vlan_20110519_02

スポンサーリンク

CiscoルータとCatalystスイッチの設定

では、CiscoルータとCatalystスイッチの設定をしていきます。

まずは、Ciscoルータから。

事前に作ったコンフィグをコピペで流し込みでもよいですが、簡単な作業かつ復習のため一行一行打ち込んでいきましょう。

「router on a stick」の場合、VLAN10・VLAN20のゲートウェイ用インタフェースは、サブインタフェースとして作成します。

Ciscoルータの設定手順

Router> en
Router#conf t
Router(config)#int fa0
Router(config-if)#ip address 192.168.0.254 255.255.255.0
Router(config-if)#no shut

Router(config-if)#int fa0.1
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0

Router(config-subif)#int fa0.2
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0

Router(config-subif)#end
Router#write memory

設定されているか確認。

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status                Protocol
BRI0                       unassigned      YES NVRAM  administratively down down
BRI0:1                     unassigned      YES unset  administratively down down
BRI0:2                     unassigned      YES unset  administratively down down
FastEthernet0              192.168.0.254   YES manual up                    up
FastEthernet0.1            192.168.10.254  YES manual up                    up
FastEthernet0.2            192.168.20.254  YES manual up                    up
FastEthernet1              unassigned      YES unset  up                    down
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
FastEthernet4              unassigned      YES unset  up                    down
Vlan1                      unassigned      YES NVRAM  up                    down

次はCatalystの設定を行います。

vSwitch側のポートやルータ側のポートをトランクリンクにする(DTPは無効)…。
Catalyst 2940は、IEEE802.1qのみサポートし、ISLはサポートしていません。そのため、[switchport trunk encapsulation dot1q]とか打たない…。

Catalystスイッチの設定手順

Switch>en
Switch#conf t
Switch(config)#int fa0/8
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport nonegotiate

Switch(config-if)#int fa0/7
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport nonegotiate

Switch(config-if)#end
Switch#write memory

設定されているかを確認。

Switch#show interfaces trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/7       on           802.1q         trunking      1
Fa0/8       on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/7       1-4094
Fa0/8       1-4094

Port
        Vlans allowed and active in management domain
Fa0/7       1,10,20,30,50,60,101-104
Fa0/8       1,10,20,30,50,60,101-104

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/7       1,10,20,30,50,60,101-104
Fa0/8       1,10,20,30,50,60,101-104

以上です。

あとは、VLAN10のホストに設定するデフォルトゲートウェイを192.168.10.254に、VLAN20側は192.168.20.254にすれば、異なるVLAN上のホスト同士で通信が出来ます。

【参考】


[第3版] Cisco LANスイッチ教科書  

スポンサーリンク
  • このエントリーをはてなブックマークに追加